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1 OVERVIEW 

IntelliDAQ – Current Sense is a system targeted at developing and validating battery powered systems 

with a wide range of current consumption.  Battery powered devices must operate at a very low 

quiescent current to conserve battery life, but must often do high current operation, such as an RF 

transmit, that can draw a large amount of current, typically for a short period of time.  IntelliDAQ allows 

you to measure current over a continuous range of 100nA to 2A.  This can be done in both a graphical, 

oscilloscope-like mode, or a continuous measurement mode where all the current that is consumed is 

measured. 

 

2 THEORY OF OPERATION 

Like most DC current measurement tools, IntelliDAQ measures the voltage drop across a burden resistor 

to determine current.  To achieve such a wide dynamic range, it uses multiple burden resistors and 

switches between them.  The switch occurs very fast and is mostly transparent to the user and the 

device under test, but you do need to be aware of it, and how it can affect how you set up your tests. 
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2.1 VOLTAGE DROP 
Because there are burden resistors inline, there will be a non-zero amount of voltage drop across the 

probes.  IntelliDAQ is designed to minimize these drops, but if your device is very sensitive, and the 

supply voltage is very low, you may see the effects.  The low range burden resistor is 10 ohms.  This 

resistor is in the circuit until you hit a current of approximately 2.5mA where the low range resistor is 

switched out.  Right before you hit the high range threshold, you will see a voltage drop of 

approximately 25mV.  Once you are in high range mode, there is a 0.1ohm resistor in series.  This will 

give you a peak voltage drop of 200mV at the max current capacity of 2 amps. 

2.2 HIGHLY CAPACITIVE LOADS 
If your device under test has a large amount of bulk capacitance, it will smooth out the load the 

IntelliDAQ will see.  This is magnified by the burden resistors, as the on-board capacitors will supply 

current while the voltage drop increased.  The total amount of current shown will be correct, but the 

timing of it will be shifted.  To get a better feel for when your device is drawing current, you can either 

reduce your bulk capacitance, or switch your IntelliDAQ into High Range Only mode.  In this mode, you 

will only have the smaller burden resistor in series, but you will lose your low-end accuracy (<100uA). 

One other effect of bulk capacitance is that you will see a current spike during the range switching 

operation.  During the range switch, the voltage drop across the burden resistors goes from 25mV to 

250uV.  This will cause a current spike during the charging of the capacitors.  This is normally not 

noticeable unless the bulk capacitance is very high, and/or the current is changing very slowly.   

In general, if you want to get the most accurate picture of when your device is consuming current, it is 

best to reduce your onboard capacitance to the minimum safe level when running in waveform capture 

mode.  When running in continuous capture mode, you can leave your designed amount of capacitance 

in place, as the total current recorded will still be correct. 

3 MODES OF OPERATION 

There are two primary modes of operation: Waveform Capture mode, and Continuous Measurement 

mode. 

3.1 WAVEFORM CAPTURE MODE 
Waveform capture mode gives you an oscilloscope like view of the current, voltage, and digital inputs.  

This operates through the local USB connection only.  To use this mode, launch the 

WaveformCapture.exe application under the IntelliDAQ program group. 
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3.1.1 Graph Info 

The top graph is the current for the entire capture.  It has one point for every 1000 samples.  There are 

two traces in this graph.  The white one is the average of those 1000 samples, and the yellow one is the 

peak of those 1000 samples.  The yellow trace makes it much easier to see short spikes in current that 

would be smoothed out by the average.  The next graph is a zoomed in selection view displayed at the 

sample rate.  You can select a portion of the capture view to zoom to by left clicking in the capture view, 

and dragging over the portion you want to view.  In the selection view, you can zoom in by using the 

mouse wheel, and can move the selection by left clicking and dragging.  The next two graphs are the 

voltage and digital view.  The scale is the same as the selection view.  You can enable and disable the 

display of any of the graphs using the view check boxes at the top of the screen.  Additionally, you can 

close any of the graphs by clicking the X at the left side if the graph.  The size of the graphs can be 

adjusted by clicking on the dots at the top of the graph and dragging. 

Summary data for the capture view and selection view can be seen at the lower right of those graphs.  

You can select a subsection of the selection view by right clicking and dragging.  Additionally, the pointer 

section at the top of the screen gives you the current, voltage, and time at the cursor. 

3.1.2 Capturing Data 
To capture data, hit the capture button.  This will capture the amount of data specified below the 

capture button.  If you need to cancel the capture, you can hit cancel on the capture dialog. 
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3.1.3 Triggers 

You can set up triggers much like you would on an oscilloscope.  The triggers can be either current, 

voltage, digital line, or digital match.  These are selected from the trigger type drop down to the right of 

the capture button.  Selecting Disabled for the trigger type will just run the capture without a trigger. 

The trigger position selects how much data will be stored before the trigger occurs.  If the trigger occurs 

prior to the trigger position, only the elapsed time will be stored prior to the trigger, so the triggered 

waveform can occur prior to the trigger position. 

The threshold specifies the trigger level for voltage and current, and the digital line(s) for the digital line 

and digital match.  The trigger edge specifies which direction it must cross the trigger, and the duration 

specifies how it must have exceeded the threshold before the trigger is considered valid (basically a 

glitch filter). 

The digital match is only looking for the level.  It will occur after an edge transition where all the levels 

match what is expected. 

3.1.4 Cursors 

There are a pair of cursors (A and B) available at the top of the screen.  These behave similar to time 

cursors on an oscilloscope.  To activate them, click on the button of the cursor you want to activate, and 

then click on the cursor bar, or the selection, voltage, or digital graphs to set the position.  You can move 

the cursor by clicking on it in the cursor bar and dragging it.  If you have both cursors selected, it will 

show the time delta between them, and the average and total current for that time period.  To turn off a 

cursor, just click on the cursor button again. 

The cursors will remain in place for subsequent captures.  If you are doing a triggered capture, they will 

be in the same place relative to the previous trigger. 

3.1.5 Ranging 
To achieve such a wide measurable current range, IntelliDAQ uses two burden resistors, and rapidly 

switches between them.  While this gives an accurate measurement of the total current used, the higher 

resistance burden resistor can affect the shape of the current waveforms, especially if the device under 

test has a lot of bulk capacitance.  To get a better view of the shape of the current waveforms, you can 

operate in high range only mode by selecting the menu option Config->High Range Only.  This is good for 

measurements in hundreds of micro amps and up, and should not be used to evaluate current 

consumption below that. 

You can select how the selection and voltage graphs are scaled, as well as the voltage input range in the 

view Preferences dialog by selecting the menu option View->Preferences. 
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Decade boundaries selects the scaling by rounding to the most significant digit of the min and max 

range.  Full Scale will utilize as much of the graph window as possible, and can create odd vertical scale 

values.  Additionally, voltage can be displayed as full scale.  

There are 2 selectable voltage input ranges: 0-5V and 0-10V. 

Additionally, in this dialog, you can configure the labels for the digital channels. 

3.1.6 Data Export/Import 

Under the File->Export menu item, you bring up the export dialog.  This allows you to export all the 

waveform data (Waveform *.cap) so that it can later be loaded back into waveform capture (this is 

binary data that will not be readable by other software).  You can also select an image which will export 

the whole window image, or csv data for use by other software.  The csv file can get very large, so you 

can select only the data you want in it to keep the size manageable. 
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3.1.7 Processing Events 

The menu item View->Process Events displays the processing events window.  This can be used to 

process all the events in the capture using the current test configuration.  The primary use case for this 

is to define event categories, and to validate configs.  Its use is described in more detail under the Test 

Configuration section in chapter 5.1. 

3.2 CONTINUOUS MEASUREMENT MODE 
Continuous measurement mode is used to measure the total current consumption of the device you are 

testing, and to record and analyze every time the current of your device increases above the quiescent 

level.  It can be run semi-autonomously in remote mode with all the processing done on the IntelliDAQ 

(this is the preferred method, and is the most robust for long tests), or can be run in a PC driven mode 

where the data is streamed to the PC  where the event processing is done.  Both modes can be access by 

launching the IntelliDAQ.exe application under the IntelliDAQ program group. 

To get the most out of your system, you should create a test configuration to characterize all the current 

events of your device under test.  This will automatically identify all the events as they are logged and 

will generate a summary of the consumption for each category.  See the Test Config section under 

configuration in chapter 5.1 for more information on how to generate a test configuration. 

3.2.1 Remote Mode 
In remote mode, all the processing is done in the IntelliDAQ device itself.  You will only use the software 

to start and stop the test, and to read out the data.  You do not need to maintain a connection with the 

IntelliDAQ during the test.  Both the IntelliDAQ application, and the automation interface can be used to 

access the data.  Any of the communications interfaces can be used.  This is the default mode selected 

when the IntelliDAQ application is launched (and is the only mode used by the automation interface).  
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To change from PC processing to remote, hit the disconnect button, then select Mode->Remote 

Processing. 

3.2.2 PC Processing Mode   

In PC processing mode, the processing is done within the IntelliDAQ application itself.  All the data is the 

same as it would be in remote mode, except that for each event logged, you will also have a waveform 

captured that can be viewed in the waveform capture application.  This is very useful if you are getting 

uncategorized events, or if you need to analyze certain events in more detail, and perhaps view voltage 

and digital inputs.  The primary negative about PC processing mode is that you must be able to maintain 

a high USB bandwidth utilization and PC CPU utilization over the entire test.  This may be difficult on a 

corporate PC where you must run virus protection etc.  This mode works best in relatively short tests 

(hours, not days or weeks).  This mode is only available over USB and is not available through the 

automation interface.  To select this mode in the IntelliDAQ application select Mode->PC Processing in 

the menu when the application is not in the connected state. 

3.2.3 Connecting 

You must first connect to an IntelliDAQ before communicating to it.  In the lower left-hand corner of the 

IntelliDAQ app, select the type of connection, and the port or IP address of that connection (there is no 

connection description required for USB).  Hit the connect button to connect to that device.  Once you 

connect to the device, you cannot change the operating mode.  If you need to change the operating 

mode, disconnect first, then change the mode, and reconnect. 

NOTE: When using the socket connection, be sure to verify the identity of the device you are 

communicating with prior to stopping a test!  You can view the name of the IntelliDAQ under the device 

tab. 

3.2.4 Loading a Test Config 

When running in remote processing mode, there will need to be a test config loaded on the IntelliDAQ.  

You can check if there is already one loaded by connecting in remote mode and hitting the Read from 

Device button on the config page.  If you need to write a new one, you can load one from a file (hit the 

Load from File button on the config page), then write it to the device.   

When running in PC processing mode, you will need to have a config loaded in the IntelliDAQ 

application.  You can load from file on the config page, or you can read one out from the IntelliDAQ if 

you want to run the same one that is one the device.  To read the config out of the device, you will need 

to be connected in remote mode.  Just remember to disconnect and switch to PC processing mode 

before starting the test.  You will also need to set the directory where you want to store the results 

using the Results Folder edit box on the config page.   

3.2.5 Starting a Test 

To start a continuous measurement test, connect to an IntelliDAQ in the IntelliDAQ App, and press the 

start test button on the Status tab.  It will bring up a confirmation dialog so that you do not accidentally 

erase data from a previous test.  If your IntelliDAQ is not set up for NTP, you should leave the Set Time 

check box checked, so that it will have a valid start time (this uses the PC time).  This time is used to 

timestamp all the event data.  When you start a test, the LED on the front of the IntelliDAQ will turn 

green.   
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NOTE:  You cannot use Waveform Capture mode while a test is running.  You must stop a test before 

starting a capture.   

After you stop a test, you can continue to read out all the information about the previous test until you 

start a new test.  Starting a new test will erase all the data from the previous test, so be sure to save 

your test data if you need it before kicking off a new test. 

3.2.6 Status View 

 

When a test is running, you can hit the update button in the status view to see the summary data, as 

well as the categorized summary.  If you select the Auto Refresh check box, it will refresh once a second. 

The following data items are available in the status view: 

• Total Consumption - The total current consumed by the device (it is in current * seconds, 

basically an energy unit without voltage).   

• Average Current - The average for the test, and is the total divided by the elapsed time.   

• Events Recorded - The number of times the device has gone above quiescent current (this is 

driven by the test config).   

• Start Time - The time the test started as seen by the IntelliDAQ device (this will be the same as 

the PC start time if the set time option was selected when starting the test).   

• Active Percentage - The percentage of time spent in an event.   

• Uncategorized Events - The number of events that did not fit into a category in the test config (a 

well characterized device shouldn’t have any uncategorized events).   

• Elapsed Time - The total time of the test.   

• Instantaneous Current - The average current over the previous second.   



11 
 

• Quiescent Current – The average for the previous second minus the consumption of any events.  

The second must start and end not in an event for this calculation to be valid.  It will display the 

last value that was valid. 

The list of category summaries contains the number of occurrences for each category, the total 

consumption for that category, and the percentage of the total contributed by that category. 

3.2.7 Event List 

 

In remote mode, to read out all the events of the current, or last run test, select the Events tab, and hit 

read.  Depending on the length of the test, and the frequency of the events, this can be a very long read.  

In PC processing mode, the events will be populated automatically. 

The dropdown box on the right will allow you to switch between scheduled summary events, and 

current events.  It will also allow you to filter on the different event categories.   

If you have uncategorized events that you want to add to the test configuration, you can right click on 

the event, and select Add Category To Config.  This will autogenerate a category configuration by 

applying a +-25% to the measured time and current consumed.  Be sure to give it an actual name before 

saving it. 

In PC processing mode, you can double click on an event to view the waveform in Waveform Capture.   
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3.2.8 Event Summary 

 

To quickly see summary information about when the events of each category are occurring and what 

the min/max/average are for the different parameters, you can view the summary tab. 

3.2.9 Scheduled Event Graph 

 

If there are scheduled events in the configuration, they can be viewed in the scheduled events graph.  

This can be helpful to visualize quiescent, peak, and average currents over time.  Voltages can also be 
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viewed on this graph.  This can be used to map external factors of the test like temperature through a 

thermocouple for example. 

3.2.10 Data Export 

Data that has been read out (through the status update, and the log read) can be exported either as raw 

data, or a comma delimited file (*.csv).  To save out raw data that can be reloaded into the IntelliDAQ 

app go to File->Save data.  This data can then be reloaded for viewing later by going to the menu item 

File->Load Data.  To export as csv data, use the File->Export To Csv option. 

In PC processing mode, it will automatically save the data to a file at the end of the test.  The location of 

the file, and the waveform files will be stored a new folder with a timestamp in it, under the folder 

specified the results folder on the test config page.  To view data later, open the results.tst file in the 

folder for the particular test. 

4 SETUP 

4.1 SOFTWARE 
Install the included windows installation package on a Windows 7 or later PC.  At the end of the 

installation you will be prompted to install the FTDI drivers for the USB interface.   

4.2 SERIAL/NETWORK CONNECTION 
IntelliDAQ has three different methods of communication: RS232 Serial, USB, and Ethernet.  Each 

interface operates the same from the software perspective in the IntelliDAQ app and automation 

interface (speeds are different), and the Ethernet interface adds a basic web interface.  The waveform 

capture app and PC processing mode for the IntelliDAQ only work with USB, as these modes need a very 

high speed, deterministic interface.  

The RS232 interface connects to a standard PC serial port or USB to serial converter.  To use this 

interface in the IntelliDAQ app select Serial from the connection type, and the specific PC serial port 

from the dropdown (all available serial ports will be enumerated).  This connection is not supported in 

the waveform capture app, as it is not fast enough. 

The USB interface will automatically configure itself if you installed the FTDI drivers at install time.  To 

use this interface in the IntelliDAQ app, just select USB from the connections drop down.  It will be 

automatically selected in the waveform capture app, as it is the only one supported. 

The Ethernet port can be configured for a static or dynamic IP (see network configuration in the 

configuration section).  It should be configured while connected to the serial or USB interfaces.  To use 

this interface, select Socket from the connection type, and input the IP address in the connection field.  

After initial use, the application will maintain a list of recent IP addresses.  This interface is not 

supported in waveform capture. 

After selecting a communications interface in the IntelliDAQ app, click the connect button to establish a 

connection.  The software will verify the connection, and will read out and display the version, serial 

number, and fixture name. 



14 
 

4.3 POWER  
Connect the supplied power supply to the 12V input on the back panel.  If the included power supply 

includes multiple blades, attach the blade that works for your location.  With the power connected, and 

the switch on the back switched on, the LED indicator on the front should be red if the device is not 

running a continuous measurement test, and green if it is 

4.4 CONNECTING TO A DEVICE FOR MEASUREMENT 
Your IntelliDAQ system came with two dual banana plug to grabber hook cables, and a 4-bit digital in 

cable.  The banana plugs have a tab on the side indicating which side is ground.  That should always go 

to the right when connecting to the IntelliDAQ (toward black for voltage, and blue for current).  The 

digital in cable is keyed, and only goes in with the center tab facing up. 

NOTE: The grounds for the voltage and digital inputs are connected together, and are connected to the 

IntelliDAQ ground.  This ground is the same as the USB and serial ground.  The current input is isolated. 

To connect your device under test for current measurement, you should connect the red lead of the 

cable connected to the current input to the battery or power supply, and the black lead to the power 

input of your device under test.  When making these connections, take care to minimize the loop area 

between the conductors.  The greater the loop area, the higher the electric field noise you will pick up 

(typically 60 hz).  This noise will not directly affect the average measurement, as it is an AC sign wave on 

top of your DC level, but it will make it more difficult to view individual events.  Additionally, you want to 

make sure the current connectors are not touching anything conductive (including an anti-static pad), as 

this can act as an antenna.  If you need to make your own cable, connect twisted pair wire to a dual 

banana plug.  Again, take care to minimize your loop area, and to keep the cable as short as possible.  If 

you are in an area with a lot of RF energy (i.e. the device you are testing has an RF transmitter), you may 

need to add ferrite beads to the cable near the banana jack to minimize RF interference. 

For most testing, you will need only the current cable connected (the fewer cables connected to your 

device under test, the less noise you will pick up).  For situations where you need more information 

(typically for bench top use using Waveform Capture), you can connect the voltage and digital inputs.  

The voltage input allows 0-10V, and the digital input allows 0-5V (greater than ~2V is considered a high 

digital signal).  These signals, can be used for triggers in Waveform Capture, and can be viewed 

graphically as well.  When connecting both the voltage and digital connections to your device under test, 

the grounds MUST be connected to the same reference point as they are connected internally. 

 

5 CONFIGURATION 

5.1 CREATING A TEST CONFIG 
To get the most benefit out of continuous capture mode, you should characterize your device with a test 

config.  This config defines categories for all the operations your device does that are above the 

quiescent current.  With these fully defined, when you are running a test, you can view the summary 
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data for the test to quickly be able to see every operation your device is doing, and how much power it 

consumes. 

You can access the test config dialog from either the IntelliDAQ app or Waveform Capture.  In the 

IntelliDAQ app, it can be viewed under the config tab.  In Waveform Capture, it can be viewed by 

selecting the menu item Config->View. 

 

 

To Create the config, you will need to manually enter the quiescent current and the event current 

threshold.  These are approximate values that are used to determine when the device has entered a 

loggable event.  The event current threshold should be significantly higher than your quiescent current 

to avoid being triggered by noise, but lower than anything you would want to log.  To determine these 

values, it may be helpful to do a capture with waveform capture to observe the quiescent current, and 

the active current of any events you may be interested in.  Make sure the event threshold is above any 

noise you may see, but below any actual event you would be interested in capturing.  The filter time is 

the amount of time to keep an event open to look for additional consumption.  It is possible to have a 

very short reduction in current that could cause the current to bounce to near zero.  This filter time 
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keeps that from creating an additional event.  The event consumption threshold is the minimum 

consumption to trigger an event.  If there are very small events in your system that you want to ignore, 

this threshold can filter them out. 

In addition to the base parameters used to define what will trigger an event, you can specify when 

summary events are logged by setting the summary log period.  These summary events contain the 

average, quiescent, and max current, as well as the min/max voltage since the last summary event.  

Setting this to 0 disables the events. 

Each category defines a min and max current consumed (in uA*Sec, basically an energy measurement 

without voltage), as well as the min and max duration.  IntelliDAQ compares to the list in order, so if a 

particular event is a subset of another, you would put the one with the tighter range first, so it can be 

distinguished from the larger one. 

To define the categories themselves, you can manually add and edit them in the New Category group 

box.  While manually editing works fine, the easiest way is to use waveform capture to define the 

categories for you.  Make sure you have the quiescent current and event current threshold set in your 

config, then capture one or more events in waveform capture (use triggers to capture them, or just do a 

long duration capture).  Select the View->Process Events menu item to open the process events window.  

Then press the Process Events button. 

 



17 
 

If you have events that are uncategorized, they will show up with the category “Uncategorized”.  If you 

double click on the event, it will highlight the event in the selection window.  You can the select the 

menu item Config->Add Section to open the Test configuration dialog with a sample config for that 

event.  It will apply a +-25% level to the thresholds.  You can modify these thresholds (or leave them as 

is), and add a description before adding the category.  If you close the Test Configuration dialog, and hit 

the process button again on the Event Processing dialog, it will reprocess the capture with the updated 

configuration. 

You can manually edit any category in the configuration by clicking on the category.  This will populate 

the fields at the bottom.  After editing, click update to update the entry.  If you select add, it will add a 

new entry with the modified parameters.  You can delete a category by right clicking it and selecting 

delete.  If you need to reorder categories, you can right click, and select move up. 

When you are satisfied with your configuration, you can hit the Write to Device button to write it to 

your IntelliDAQ device.  Additionally, if you plan to use this configuration on other IntelliDAQs, or just 

want to back it up, you can save it by hitting the Write to File button.  Additionally, you can load an 

existing config by hitting the Load from File button. 

If you find that you are getting uncategorized events when running in continuous capture mode, you can 

add them to the test config (only helpful if you know what they actually are) by right clicking on the 

event and selecting add to test config. 

5.2 CALIBRATION 
Your IntelliDAQ was factory calibrated for both gain, and offset, and has a continuous offset calibration 

mechanism.  In normal circumstances, it should not need recalibration.  If you feel that your device 

needs to be calibrated, select the Config->Calibrate menu item in the waveform capture app or select 

the device tab in the IntelliDAQ app, and select Calibration.   
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To calibrate the offset, make sure there is nothing connected to the current input (remove the cable), 

and hit the Offset Cal button.   

To calibrate either the low or high gain ranges, you will need to first select the Enable Slope Calibration 

check box (this is in place to avoid accidental modification of calibration). 

Prior to calibrating, make sure you have a stable current source in the ranges recommended (100-500 

uA for low range, and 5-500mA for high range).  If the resulting calibration is out of range (because of a 

reference current different than entered), then the calibration will not be accepted, and an error 

message will be displayed. 

When calibrating the slope, always do an offset calibration first to ensure the highest accuracy, then 

calibrate the low range, then the high range. 

In the event that you have run a calibration that is not valid, you can always revert to the factory 

calibration by hitting Revert to Factory. 

 



19 
 

5.3 NETWORK CONFIGURATION 
To configure the network interface, you must be connected to an IntelliDAQ (preferably via serial or 

USB) in the IntelliDAQ app, and select the Device tab, and select Network. 

 

Use the address config to select whether it is a static IP or dynamic one.  If it is static, fill in the IP info.  

Additionally, you can configure the hostname as well as the time server.  If a time server is configured 

and enabled, the device will keep time synchronized.  This is primarily important when running in event 

mode. 

The network status field will display the current IP address for the device.  If the configuration is 

changed, hit the Configure button to write the config to the IntelliDAQ.  To see an updated status 

(primarily needed when in dynamic address mode), you can hit the refresh button in the status pane. 

 

5.4 UPGRADES 
The firmware on your IntelliDAQ is upgradeable.  After downloading the image (or receiving on from 

Harborside support), you will use the IntelliDAQ app to do the upgrade.  With a device connected, go to 

the Device tab.  The upgrade section will be at the bottom.  Hit the browse button to select the new 

image, and hit start.  The status bar will give you an indication of the upgrade process.  Toward the end 

of the process, you will see the LED on the front turn off for several seconds before turning back on.  

This is part of the upgrade process.  At the end of the upgrade, the Identification pane will display the 

new firmware version number. 
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6 AUTOMATION 

The automation interface is a COM object that gives you access to everything that you can do within the 

IntelliDAQ Continuous Measurement PC application.  While the PC application gives the user a good way 

to interface the device and analyze the data, the automation interface gives you all the tools to integrate 

it into your automated verification system.  See the automation interface specification included in the 

doc section of the install directory, as well as the included scripting samples for how to use the interface.   

7 TROUBLESHOOTING 

7.1 CANNOT CONNECT TO DEVICE 
This can either mean that there is an issue with the selected communications interface, or another 

application is holding a connection to the IntelliDAQ.  Waveform Capture disconnects after each 

capture, but the IntelliDAQ application maintains a connection until you disconnect.  If you get the error 

in Waveform Capture, check to see if you have the IntelliDAQ application open and connected before 

troubleshooting the physical connection. 

7.2 TEST RUNNING CAPTURE BLOCKED 
If you get this error in waveform capture, that means that there is a continuous capture test running on 

the IntelliDAQ you are talking to.  You should see the power/test LED as green.  You will have to stop the 

test before you can do a waveform capture.  Connect with the IntelliDAQ app and select stop test. 

7.3 ERROR IN TRANSFER 
If you are getting the error in transfer dialog during long captures, or during triggered captures, you may 

not have enough available bandwidth on the USB bus.  This is usually cause by a USB hub.  For best 

performance, connect the IntelliDAQ directly to your PC.  Additionally, avoid using other high bandwidth 

USB devices on your PC at the same time.  Typically, USB ports grouped together on your PC are on an 

internal hub.  Minimize the devices plugged into the same USB group as your IntelliDAQ. 

7.4 AC IN WAVEFORM 
If you are getting large AC swings in your captured waveform, you are picking up electric field noise.  The 

best way to minimize this is to minimize the loop area of your cables, and make sure none of the 

conductors are connected to anything conductive (even an anti-static mat can cause problems).  

Twisting a pair of wires together is the best way to minimize loop area. 

7.5 RF IN WAVEFORM (SQUARE WAVE CURRENT INCREASE) 
It is possible to get invalid waveforms dues to RF getting into the IntelliDAQ.  Move RF antennas as far 

away as possible from the current conductors.  If your device under test is transmitting, make sure its 

antenna is not close to the conductors.  If you are still having problems, you can place one or more 

ferrite beads over the cable where it enters the IntelliDAQ.  This will help suppress the RF before it can 

get into the case. 
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7.6 ROUNDED WAVEFORMS 
The IntelliDAQ will capture the current your overall device is pulling from the power supply, but that 

may not accurately represent the current demand of the active devices on your board.  If you have a 

large amount of capacitance on the board, you will lose a lot of detail.  While the production version of 

your board may need the capacitance, if you are trying to fully characterize the current load, you may 

need to remove some of it in a development setting. 

7.7 SPIKES IN WAVEFORMS IN THE 2-4 MA RANGE 
If you are seeing current spikes in the 2-4 mA range that are not cause by your device, it may be due to 

the range switching.  If you have a very large amount of capacitance on your board, and you current is 

changing very slowly, you will see large current spikes as the voltage drop due to the burden resistors 

changes when the range switches.  If you are not measuring a wide dynamic range, select High Range 

Only under the config menu.  This will prevent range switching.  Alternatively, you can remove some 

bulk capacitance from your board.  

 

8 SUPPORT 

For tech support, reporting bugs, or just general feature recommendations, please email: 

support@harborsidetechnology.com.  Please reference the product name, and be as detailed as 

possible if reporting a bug.  We appreciate your feedback! 

mailto:support@harborsidetechnology.com
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